When I add a clue to an existing hunt, KAK still generates a QR code for older hunt


#1

i made a hunt, with 11 clues. complete with pics, quizzes, poll, etc. it all worked great.

I generated a qr code poster and it worked great.

the next day, I decided to add one more clue to make it 12 clues. saved & everything.

when I print a qr code now, it still links others to the 11 clue hunt.

what’s up with that?

I even tried deleting the 12th clue and building it all from scratch. nope.

I reordered the 12th clue so that it’s now #10. and previous 10 & 11 are now 11 & 12. nope. that new clue just doesn’t show up in a qr code poster.

?!?

fine app, by the way. I look forward to using it a great deal for work & hobby stuff! wonderful potential. I will share this within my industry. they will eat this stuff up!


#2

I just tried generating a hunt code. nope.

that code lead to a hunt with 11 clues, not 12.

I’m sending the code to myself using the print/email method.


#3

Sounds like it didn’t save the changes to the server properly. Try this:

  • Go to Info->Diagnostics->Backups of Recent Hunt Saves, and verify your hunt is there. Assuming you haven’t deleted Klikaklu and reinstalled it, there should be. There will likely be multiple copies, with the most recent saves at the top.

  • Go to Info->Diagnostics, and tap Clear Cache. If it complains of unsaved data, first quit Klikaklu then restart it (to quit an app: tap once on the home button to go back to the springboard, then tap twice to see a list of recent apps. Then swipe up on Klikaklu’s miniscreen). Once again go to Info->Diagnostics, and tap Clear Cache. This time say you want to discard unsaved data. Wait a few seconds, then tap it again. It should no longer complain of unsaved data.

  • Go to Info->Diagnostics->Backups of Recent Hunt Saves, select the ones you want, change its title a little, and press Save. You should see a progress bar appear, telling you it’s saving.

This will cause a new hunt to be created, which will have a new QR code. Print that out, and it should work for you.


#4

If you want, I can help diagnose this offline. Send me an email with your hunt name, and I’ll look into it.


#5

I tried your fixes. The new code is visually different. Scanning it with a different device brought up a hunt with 12 clues. I’m going to go try it now. Any way to avoid this in the future? Thanks for the potential fix!